Jump to content

drgonzo

Player
  • Content count

    14
  • Joined

  • Last visited

Posts posted by drgonzo


  1. Hello,
    maybe some of you can help me with my vanilla client related problem.

    My Problem:
    When I am starting WoW with the legacy logs launcher it starts very fast and smooth. 
    But when I am starting WoW with WoW.exe my whole Windows and all programms starts to lag really bad during starting process.

    The start itself takes ages compared. My mouse starts to lag. When I am in discord my voice and the voice of others sounds like a robot.
    Also the login process after initial WoW start takes much longer and my pc starts to stutter/lag again.
    After I logged in everything is fine. 120 Hz, ~ 200 fps.

    My Setup:

    • Intel Core i7 7700K
    • Samsung 850 Pro, 512 GB
    • 16GB (2x 8192MB) HyperX FURY DDR4-2666 DIMM CL15-17-17
    • MSI GeForce GTX 970 Gaming 4G
    • first monitor: ViewSonic XG2703-GS. Gsync, 144 Hz, WQHD
    • second monitor: NEC MultiSync EA274WMi, WQHD
    • Windows 10 Professional x64


    What I tried so far:

    • disabled AntiVirus
    • disabled Windows10 game mode
    • disabled Nvidia recording/streaming options
    • disabled Gsync
    • lower resolution / lower framerate / lower details
    • all my drivers are up to date
    • started WoW as administrator

    Any suggestions?


  2. 16 hours ago, Julian said:

    Pretty sure rankers only AFK when they know their team is going to lose, and they don't want to extend the game, because rankers have enough knowledge about PvP to know that sometimes letting the other team win for quick 700 honor is better than having an hour long 2-3 loss. And horde pugs just simply don't work towards a common goal sometimes, and most just only attack an alliance thats in front of them when winning a game quick gives you alot more honor per hour.

    I will report every single one of the them. Have fun farming Honor while being temp banned.

×