Jump to content
Shino

DPSMate - A combat analyzation tool

Recommended Posts

33 minutes ago, Malga said:

@shino

Is there any plan to retreive all the old logs ?

The ancient log, our very first raids etc... are something kind of precious for us... nostalgia etc

Tell me if the old files are lost or if we have a chance to retreive them

They are not lost, they are still saved on my HDD, but the server cant handle so large databases.

cheers!

Share this post


Link to post
Share on other sites

Hi, I would like to know if there is any way to make the DPSmate show the numbers of my totems... The searing totem/magma totem or healing ward aren't showing up on it and they are a big part of my DPS/HPS. Thanks.

Share this post


Link to post
Share on other sites
27 minutes ago, toonlink015 said:

Hi, I would like to know if there is any way to make the DPSmate show the numbers of my totems... The searing totem/magma totem or healing ward aren't showing up on it and they are a big part of my DPS/HPS. Thanks.

In vanilla the api does not provide you information about the ownership of totems. So if there is more than one shaman, DPSMate couldnt tell for most totems which belongs to whom.

So it is not shown in your player tab.

Deactivate only show party to see it.

Share this post


Link to post
Share on other sites
1 hour ago, yourcontentwillneed said:

Is there any reason you show DPS to the left of the total when the retail addon ur emulating doesnt even do that?

why would i want to see (900 dps) 52131

doesnt even make sense

 

Im not emulating any retail addon, they all look alike anyway.

Go into options and change it if you want.

Share this post


Link to post
Share on other sites

Hey Shino, love the addon man, but I'm getting this nasty error for when I'm downloading DPS mate to link with the legacy logs, and what not. Here is the error I'm getting. "DPSMate.lua202:attempt to index field 'content border color' (a nil value)

Would appreciate some feedback.

Share this post


Link to post
Share on other sites
1 hour ago, Slyman said:

Hey Shino, love the addon man, but I'm getting this nasty error for when I'm downloading DPS mate to link with the legacy logs, and what not. Here is the error I'm getting. "DPSMate.lua202:attempt to index field 'content border color' (a nil value)

Would appreciate some feedback.

You were probably upgrading from an very old version to a new one. You need to delete DPSMate.lua and DPSMate.lua.bak from your WTF folder in all subfolders.

cheers!

Share this post


Link to post
Share on other sites

hey, have the issue after installing modui

Цитата

 Attempted to register too many CVars
DPSMate
DPSMate_DataBuilder.lua
663
1

Clearing every files in WTF cache didn't helps...

Any Ideas how to fix it?

Share this post


Link to post
Share on other sites
1 hour ago, Lyushen said:

hey, have the issue after installing modui

Clearing every files in WTF cache didn't helps...

Any Ideas how to fix it?

Open up the addon file at this line and comment out this cvar registration

Share this post


Link to post
Share on other sites
52 минуты назад, Shino сказал:

Open up the addon file at this line and comment out this cvar registration

yeah, thanks, fixed. I've commented whole section of this CVars. 

but still in turmoil, which was the cause of this issue...

Edited by Lyushen

Share this post


Link to post
Share on other sites
2 hours ago, Lyushen said:

yeah, thanks, fixed. I've commented whole section of this CVars. 

but still in turmoil, which was the cause of this issue...

Not sure, I dont understand how the cvars work on the vanilla client. As it seems they can only be written once. Hence if multiple addons try to register/modify these variables there will be an error.

Havent really figured out how to solve this issue yet.

Share this post


Link to post
Share on other sites
1 hour ago, Shino said:

just target yourself, this should solve your problem

Thank you. That seemed to do the trick.

 

Can you fill me in on the Threat window, and how it works? - I would've thought it takes information from KTM, but it doesn't seem to work like that. Currently it's showing only 1 guy in my party having 100% of the aggro, while KTM is giving me the full information.

 

Another question. How does the Segments work? I was under the impression that you could have "Total Damage" showing and then you could switch to "Current Fight" for bosses, to show damage for only that fight. But that doesn't seem to be the case, since it thinks the whole run as a single fight/segment? - Timer says 80 minutes now for a run I've done, even though we've been out of combat in between. Does that mean I have to manually make new segments, when I want to track the information for a single boss/fight fast?

Is there some limit in Vanilla that makes it impossible for the addon to create segments itself when choosing "Current Fight" and it just tracks from combat till leaving combat automatically?

 

If this is all just me, then I'm sorry.

Share this post


Link to post
Share on other sites
6 minutes ago, Discodolphin said:

Thank you. That seemed to do the trick.

 

Can you fill me in on the Threat window, and how it works? - I would've thought it takes information from KTM, but it doesn't seem to work like that. Currently it's showing only 1 guy in my party having 100% of the aggro, while KTM is giving me the full information.

 

Another question. How does the Segments work? I was under the impression that you could have "Total Damage" showing and then you could switch to "Current Fight" for bosses, to show damage for only that fight. But that doesn't seem to be the case, since it thinks the whole run is a single fight? - Timer says 80 minutes now for a run I've done, even though we've been out of combat in between. If I switch to "current fight" it just shows the total as well, which makes me think it's belives the entire instance is one big fight.

The without legacy logs version is currently bugged with some segments.

The threat feature seems to be bugged atm as well. sorry^^

Share this post


Link to post
Share on other sites
3 minutes ago, Shino said:

The without legacy logs version is currently bugged with some segments.

The threat feature seems to be bugged atm as well. sorry^^

No problem.

 

So the segments are supposed to work kind of how I thought they should/would?

 

And no problem on the stuff being bugged. Hope you find a fix for it, though! :)

Share this post


Link to post
Share on other sites
1 minute ago, Discodolphin said:

No problem.

 

So the segments are supposed to work kind of how I thought they should/would?

 

And no problem on the stuff being bugged. Hope you find a fix for it, though! :)

Current fight just shows you the current fight, then there are segments which lets you review recent current fights.

But its not working atm in the newest version, so you got 2 totals I guess^^

Share this post


Link to post
Share on other sites
1 minute ago, Shino said:

Current fight just shows you the current fight, then there are segments which lets you review recent current fights.

But its not working atm in the newest version, so you got 2 totals I guess^^

Thanks for clearing that up. I hope you find a fix! :)

Share this post


Link to post
Share on other sites

Hey there Shino, I keep getthing this dps mate addon error, says "Error: Couldn't find CVar named 'CombatLogRangeParty'. Thanks for getting back to me the first time, hope to hear back soon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×