Jump to content
Sign in to follow this  
hybbo

Addons bugs the game

Recommended Posts

I´ve been sitting all morning arranging my UI with various addons. When im later going to play, i cant move or interfere with the game. So im troubleshooting my addons one by one. Finally im narrowing it down to be cartographer and questhelper who are messing the game up. I´ve tried addons from diffrent webpages etc but i cant get them running. Without just thoose two the game gets unplayable to me.

 

Anyone been through anything similiar and sorted it out?

 

Peace Hybbo

Share this post


Link to post
Share on other sites

Similar issue indeed, glad you narrowed it down. Currently using only the absolute minimum. Hope this will be fixed soon.

Share this post


Link to post
Share on other sites

Try different sources of addons such as;

http://tbcwowaddons.weebly.com/

https://legacy-wow.com/tbc-addons/

Also curse if the addon still exists look for the 2.4.3 version on curse and it should work as well. I got almost all of my addons from the first link - but I am using the beta branch of pFUI from www.shagu.org for my UI replacement. pFQuest also recently got a beta for TBC as well and is an alternative addon to Questie.

 

Share this post


Link to post
Share on other sites
3 minutes ago, Zancon said:

Try different sources of addons such as;

http://tbcwowaddons.weebly.com/

https://legacy-wow.com/tbc-addons/

Also curse if the addon still exists look for the 2.4.3 version on curse and it should work as well. I got almost all of my addons from the first link - but I am using the beta branch of pFUI from www.shagu.org for my UI replacement. pFQuest also recently got a beta for TBC as well and is an alternative addon to Questie.

 

Yeah! I've tested alot diffrent sites to download them from. I've done more troubleshooting during the day. The thing is Questhelper gives me one kind of problem and cartographer gives me another. I've tried diffrent servers and diffrent characters on the very same realm.

But the problem stays with my main Warlock on Stormgarde. Questhelper gives me problem to interract with NPC,s and on some ocassions spells. It doesnt work simply, just like its lagging but my Latency and FPS is rock solid.

Cartographer makes my Warlock unable to move, interact in game and the menu doesnt work. I can rotate the character and check spellbook, character tab. But thats all!

I figure this beeing some really weird problem that seems impossible to solve. My last way out is to sell the character, its sad though!

Share this post


Link to post
Share on other sites

I sorted it all out by /gquit even though it didnt display i was in a guild. Case closed

Share this post


Link to post
Share on other sites
2 hours ago, Zancon said:

Your best way out is to simply not use the addons giving you issues.

That's pretty passive aggressive Zancon...   Players are experiencing a real issue and it is a server side problem and we just proved it.

I've been testing this Issue for hours and have some results that are interesting. 

My main would only spin around with everyone one else in orgrimmar just running in place with Unknown titles. 

Similar to Hybbo I found that the issue only happens on my Main, not on other characters. And only with addons on.

Using the /gquit was the only way to solve the issue.

Somehow the guild information you guys transferred is bugged.

This is obviously a server side issue. You need to inform the other mods and make a general post because everyone is having this issue. 

 

Share this post


Link to post
Share on other sites

It's not at all my intention to be passive aggressive. We don't control addons. If the addons are broken and resetting your addons by clearing your WTF and WDB folder isn't working than the only choice to a fresh download and reinstall of those addons. If that doesn't work then not using that addon and looking for an alternative with the same or similar functionality is the next step. If that doesn't work not using addons is the option.

This is not at all a server side option. The server doesn't manipulate addons.

You are mixing issues - addons are one issue. Large guilds are another separate issue. Large guilds are an issue because we unlock the amount of players allowed in a guild. In retail, I believe this number was 300. That's not an addon issue, that issue is with how the core handles guild tables and is separate.

 

All of us are learning the quarks of this and I am a single person handling support requests for thousands of people. I apologize if my comments are short, but I can only spend a limited time with each person or everyone would be awaiting a response for days.

Share this post


Link to post
Share on other sites

I'm not the one one mixing issues, the game is.

I have no idea how the problem with the addons was solved by /gquit. 

But it is clear there is some kind of connection. 

As I tried to explain I've tested this. I did delete WTF and WDB multiple times, deleted and reinstalled addons. Still the issue only on main character.

1 hour ago, Zancon said:

 

This is not at all a server side option. The server doesn't manipulate addons.

Somehow being in a guild was triggering the issue. These addons work perfectly fine. You're getting really hung up on it being the addons fault, but it is the opposite.

The Stormrage guilds are what is causing the problem.

It seems you are just ignoring the information players are testing and showing you. Idk man I get you have a lot to manage here, but I don't think you are really listening to us. 

It would be like making a statement " Stormrage does not allow you to be in a guild and run addons, but it's the addons fault not ours... even though those addons work fine on other servers with guilds, we will not take any responsibility, it's not our fault we don't care. It's the addons fault. " 

Like wtf man..................

 

Share this post


Link to post
Share on other sites

Every single post in this thread was about addons at the beginning. There are many addons with issues - it's hard to troubleshoot those issues because we don't know if they are using the proper versions for TBC, within the TBC versions many addons have several releases so which release are they using?

There are separate issues - some ARE addon related and some are server CORE related. We narrowed it down, within the purview of this specific thread that it was a core issue related to guild size. Simply being in a guild isn't an issue. Being in a guild with more than 300 people is an issue our development team is working on. Right now the work around is to either cut the guild size below 300 users or to quit the guild yourself.

Consider that I am talking to and helping many people and not every solution is the same for all of them. This thread was about addons, so the trouble shooting was about addons. Over the course of the thread and with more information gained, specifically to our own testing and listening to user issues we found the core issue and the conversation has shifted due to this new information.

Share this post


Link to post
Share on other sites

Thank you now I think people will understand how to solve their issue and it sound like the problem is exposed. 

 

Fix:

1. Use /gquit ( you may have to  delete WTF, WDB, and your addons to reload and use /gquit before fully reinstalling addons)

or

2. Play without addons. ( delete WTF, WDB, and your addons) 

It may just be questing addons such as carbonite and questie that are crashing due to the server error with guilds of 300+ members. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×