Jump to content
Oz1956

Can't join general chat

Recommended Posts

Hi, I'm new here, great game, almost pure vanilla. Thank you. Now my problem is that now that I've reached 15 and am now almost a level 16, I still cannot access the chat channels. I have tried typing  /join General, but nothing happens. When I hit enter, it still comes up as just "say". Can someone tell me what I'm doing wrong, plz? Thank you.

Share this post


Link to post
Share on other sites

The "general" channels are in capitol cities. The main chat channel on our realms is "World" so please do the command /join world. It will assign this channel a number. For example the number might be 5. Then do "/5 Hello!" or whatever number it turns out.

Now, if this still doesn't work and you can't whisper people or chat otherwise, then something happened and you have been caught up in our automatic anti-spam feature, which sometimes has a mind of its own. Don't worry though, just click the red "?" near the bottom of your screen on your mini bar and submit a ticket to our GM team and they can get you all fixed up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×