Jump to content
Sign in to follow this  
almegdufas

Addons not showing up

Recommended Posts

Hey everyone!!!

I just recently downloaded a couple of addons and for some reason they are not showing up and I don't have a way to enable the addons. I downloaded the addons from GitHub and extracted the zip files to the addons folder. I have restarted my client as well as my computer and I am not sure what to do. I am not sure what I need to do but if someone could help I would really appreciate it. Also sorry if this is some 101 stuff I am not the best with this sort of thing.

Addons downloaded:

Addon Organizer

Cartographer

Hunter Swiss Knife

Share this post


Link to post
Share on other sites

When you say they are in the addons folder, do they each have their own folder there?

Have you enabled them from the character selection screen?  I can't remember whether addons are enabled by default but i would start there.  

If the addons are out of date you will need to force them to load from the addons screen. Addons have an indicator to say which version of the client they are for, you have to force them to work with later versions. This is due to interface changes between versions.  Forcing out of date addons to load may lead to odd behaviour or even freezing.

The other possibility is that the addons are loading but you don't see them because you need to set them to display.  When the client loads, addons sometimes put messages to this effect in the client log.  Or you can check the addon folder to see whether there is a readme file that may help.

Edited by wampuskitty

Share this post


Link to post
Share on other sites

Many addons from GitHub will have -master at the end if the addon folder name. Make sure you are removing that part.

Share this post


Link to post
Share on other sites
3 hours ago, Zancon said:

Many addons from GitHub will have -master at the end if the addon folder name. Make sure you are removing that part.

I did delete the "-master" from the end of the addon folder name.

Share this post


Link to post
Share on other sites
5 hours ago, wampuskitty said:

When you say they are in the addons folder, do they each have their own folder there?

Have you enabled them from the character selection screen?  I can't remember whether addons are enabled by default but i would start there.  

If the addons are out of date you will need to force them to load from the addons screen. Addons have an indicator to say which version of the client they are for, you have to force them to work with later versions. This is due to interface changes between versions.  Forcing out of date addons to load may lead to odd behaviour or even freezing.

The other possibility is that the addons are loading but you don't see them because you need to set them to display.  When the client loads, addons sometimes put messages to this effect in the client log.  Or you can check the addon folder to see whether there is a readme file that may help.

I do not have the option to enable them from the character selection screen. I know normally it should be toward the bottom left of the character selection screen but it is not there.

Share this post


Link to post
Share on other sites

Then something went wrong with the install. See if there are more folders under the main folder and drag them out into the main addons folder. Such as if you have an addon called "MegaAwesomeUI" and it has another sub folder also called "MegaUI" inside of the "MegaAwesomeUI" folder drag the "MegaUI" folder into your /Addons/ folder and see if that does anything for you.

 

We will figure this out!

Share this post


Link to post
Share on other sites
8 hours ago, Zancon said:

Then something went wrong with the install. See if there are more folders under the main folder and drag them out into the main addons folder. Such as if you have an addon called "MegaAwesomeUI" and it has another sub folder also called "MegaUI" inside of the "MegaAwesomeUI" folder drag the "MegaUI" folder into your /Addons/ folder and see if that does anything for you.

 

We will figure this out!

This got it working. After I dragged the sub folder out there is now the addon button in the character selection screen. Thank you for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×