Jump to content
Sign in to follow this  
Blusero

Guild Registering Issue

Recommended Posts

Hello! I'm having an issue when registering a guild chart. I've already bought mine, I have made my members signed it. But when I go to the guild master NPC and want to register it, nothing happens. 

I've seen a post from 2016 that this happened before, but it seems that this issue was solved somehow...  Now its happenin' again,

I open this topic to let you know know about this problem and maybe you can fix it. Thanks for your attention.

Share this post


Link to post
Share on other sites

Clear the top left slot in your original backpack and place the charter there and try again.

Sometimes you have to transfer it to your bank. Relog. Put it in your first slot and then turn it in.

 

Sometimes you have to do the above but when you relog you also have to clear your WDB.

 

This is the same with some quest items. It's a strange bug, apologies for the inconvenience. 

Share this post


Link to post
Share on other sites
31 minutes ago, Zancon said:

Clear the top left slot in your original backpack and place the charter there and try again.

OMG this worked! Thank you VERY VERY much!! 😄

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×