Jump to content
kittenbasher

[Guide] 2FA (mostly?) iOS fix

Recommended Posts

Hello my dudes, I've been recently somewhat active in the support channel on Discord and there's been a lot of people having issues with their 2FA codes not being accepted.

After we got several people troubleshooted on the issue, on the suggestion of Ashlol I've decided to put together this short semi-comprehensive guide on getting it up and running again.

  • Most Android users reported success with going to the app settings (clicking a triple dot, more settings) and selecting 'synchronize with server', or something along those lines - I'm not an Android user, but you can surely figure it out with this information. However the iOS app has no such setting which brings me to the next point, unsuccessful Android users can try this out as well.
  • ------------------------------------------------------------------------------------------------------------------------------------
  • On iOS, go to Settings => General => Date & Time => Enable "Set Automatically" (MAKE SURE YOUR DEVICE IS CONNECTED TO THE INTERNET), then restart your device, run the app and scan/enter the code from your 2FA activation e-mail again.
  • If the above didn't work for you, try enabling Location Services and restart + rescan again.
  • If you are getting the Contact customer service message / Could not login to World of Warcraft please try again later, your account has been locked out for too many attempts and have to wait for 30 minutes before trying again.
  • This guide is aimed at the Google Authenticator app, you can try to follow similar steps with other apps but no guarantees here.

 

Hope this helped you out as it helped the others, and see you in Azeroth.

 

PS:  If all else fails, you can attempt to remove the 2FA in control panel by clicking "Change your two-factor authentication" => "Remove IP lock with authenticator" => Open the e-mail link and enter your code, log-in to the game and then activate 2FA again. You can of course skip the reactivation part but I strongly recommend against that for security reason. As the absolute very last resort you can get 2FA removed here: https://forum.elysium-project.org/forum/491-2fa-removal-requests/

 

Share this post


Link to post
Share on other sites

Android user here, it did not work for me synchronising again. In fact the modal told me that it was already synced to the google server.

Share this post


Link to post
Share on other sites

didn't work on android for me, then I tried removing my authenticator and now it just says "could not log into world of warcraft at this time. please try again later"

Share this post


Link to post
Share on other sites

Tried your Android fix, I now have 2 different Authenticators set up giving me the same rotating codes - Still constantly can't log in to game server.  Authentication codes work perfectly fine logging in to Elysium Control Panel website

Share this post


Link to post
Share on other sites

Don't know if this has been posted anywhere but. I had some issues the other day as well (I was 100% sure everything was entered correctly), what solved it for me (after getting locked out -> waiting) was:

Opening Wow, filling in the Username and Password (but not hitting enter/connect). If not 100% typing the password in a notepad (or similar) to ensure that there are no spelling mistakes as it's visible.

Then opening the Authenticator on my phone and wait until a new fresh code pops up.

Then immediately in the Wow Client hitting enter/connect and typing in the new fresh code (some delay here, can't enter it too fast).

And then I could connect.

Edit: Meaning - if I'd try to enter the Authenticator code when it was already a quarter- or halfway due to be expired - it would fail. 

Share this post


Link to post
Share on other sites

Greetings,
 

There have been some desync issues today.
Unfortunately, those caused the 2FA not to function properly.

They have been resolved by now and that might fix the problems some of you were having.


Best regards,

Nemesis

Share this post


Link to post
Share on other sites
Guest

The responses in this thread were vague so I apologize if this is duplicating efforts, but also ensure that your phone is set for automatic date & time and automatic time zone if applicable. For Android, you can find this in Settings -> Date & Time (may be slightly different per phone, this is Google Pixel for reference). The authentication app must be sync'd, but the authentication app being sync'd will not help you if your phone is not set to automatically grab the correct date & time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×