Jump to content
Quack

[Download]: Server launcher and diagnostics tool

Recommended Posts

Players who experience client sided issues or don't know how to change their realmlist contact us daily. It is also known that some players play on multiple servers and look for a tool to switch between those easily while having a clean cache.

Hence we release our batch based launcher which was primary in use by the team of Elysium Project, it is easy to use and open source.

Advantages of this launcher:

  • A simple .bat script hence you can read/edit the code
  • No hidden malware, it is open source so everyone can confirm his part
  • Choose between 3 servers
  • Set various tweaks (e. g. automatic cache cleaning on startup or usage of OpenGL)
  • Automatically fix client sided issues (e. g. instant disconnect after login)
  • Do a semi-reset of the client if you experience unusual client behaviour
  • Run client diagnostics to find possible issues
  • Enable/disable custom MPQ files on demand
  • Tiny filesize (12kb)

Disadvantages of this launcher:

  • It looks rather old fashioned
  • It has no automatic updates
  • It requires keyboard input

Compatible expansions: Vanilla and TBC
Compatible operation systems: Windows 2k/XP/Vista/7/8/10
Current version: v10 April 2018 (v1 started in June 2006)

 

Download:

http://www.filehosting.org/file/details/742666/LaunchWoW (1).bat

Share this post


Link to post
Share on other sites

Seems to work perfectly. I am however still experiencing disconnects on login, I am now suspecting it may be a timeout, caused by my long loadtime. Can anyone tell me if switching to openGL, would increase or decrease my overall gpu demand/performance? Any other suggestions maybe ?
My config:

Spoiler

SET hwDetect "0"
SET gxColorBits "24"
SET gxDepthBits "24"
SET gxResolution "1280x768"
SET gxRefresh "60"
SET gxMultisampleQuality "0.000000"
SET fullAlpha "1"
SET lodDist "100.000000"
SET SmallCull "0.010000"
SET DistCull "500.000000"
SET frillDensity "48"
SET farclip "537"
SET specular "1"
SET particleDensity "1.000000"
SET unitDrawDist "300.000000"
SET movie "0"
SET readTOS "1"
SET readEULA "1"
SET realmList "logon.elysium-project.org"
SET gxVSync "0"
SET gxWindow "1"
SET accountName ""
SET mouseSpeed "0.60000002384186"
SET Gamma "0.900000"
SET profanityFilter "0"
SET MusicVolume "0"
SET SoundVolume "0.30000001192093"
SET MasterVolume "0.20000000298023"
SET weatherDensity "0"
SET useWeatherShaders "0"
SET ffxGlow "0"
SET ffxDeath "0"
SET realmName "Nighthaven"
SET cameraYawMoveSpeed "180"
SET cameraYawSmoothSpeed "180"
SET cameraDistanceMaxFactor "2"
SET gameTip "55"
SET AmbienceVolume "0"
SET uiScale "1"
SET useUiScale "1"
SET UnitNameNPC "1"
SET cameraSmoothStyle "0"
SET cameraPivot "0"
SET checkAddonVersion "0"
SET scriptMemory "131072"
SET assistAttack "1"
SET deselectOnClick "0"
SET autoSelfCast "1"
SET ffx "0"
SET M2UseShaders "0"
SET DesktopGamma "1"
SET lastCharacterIndex "3"
SET EmoteSounds "0"
SET EnableErrorSpeech "0"
SET EnableAmbience "0"
SET gxMaximize "1"
SET cameraView "4"
SET minimapInsideZoom "0"
SET minimapZoom "0"
SET MasterSoundEffects "0"
SET patchlist "logon.elysium-project.org"

 

Share this post


Link to post
Share on other sites
26 minutes ago, SammyTheSalmon said:

Seems to work perfectly. I am however still experiencing disconnects on login, I am now suspecting it may be a timeout, caused by my long loadtime. Can anyone tell me if switching to openGL, would increase or decrease my overall gpu demand/performance? Any other suggestions maybe ?
My config:

  Reveal hidden contents

SET hwDetect "0"
SET gxColorBits "24"
SET gxDepthBits "24"
SET gxResolution "1280x768"
SET gxRefresh "60"
SET gxMultisampleQuality "0.000000"
SET fullAlpha "1"
SET lodDist "100.000000"
SET SmallCull "0.010000"
SET DistCull "500.000000"
SET frillDensity "48"
SET farclip "537"
SET specular "1"
SET particleDensity "1.000000"
SET unitDrawDist "300.000000"
SET movie "0"
SET readTOS "1"
SET readEULA "1"
SET realmList "logon.elysium-project.org"
SET gxVSync "0"
SET gxWindow "1"
SET accountName ""
SET mouseSpeed "0.60000002384186"
SET Gamma "0.900000"
SET profanityFilter "0"
SET MusicVolume "0"
SET SoundVolume "0.30000001192093"
SET MasterVolume "0.20000000298023"
SET weatherDensity "0"
SET useWeatherShaders "0"
SET ffxGlow "0"
SET ffxDeath "0"
SET realmName "Nighthaven"
SET cameraYawMoveSpeed "180"
SET cameraYawSmoothSpeed "180"
SET cameraDistanceMaxFactor "2"
SET gameTip "55"
SET AmbienceVolume "0"
SET uiScale "1"
SET useUiScale "1"
SET UnitNameNPC "1"
SET cameraSmoothStyle "0"
SET cameraPivot "0"
SET checkAddonVersion "0"
SET scriptMemory "131072"
SET assistAttack "1"
SET deselectOnClick "0"
SET autoSelfCast "1"
SET ffx "0"
SET M2UseShaders "0"
SET DesktopGamma "1"
SET lastCharacterIndex "3"
SET EmoteSounds "0"
SET EnableErrorSpeech "0"
SET EnableAmbience "0"
SET gxMaximize "1"
SET cameraView "4"
SET minimapInsideZoom "0"
SET minimapZoom "0"
SET MasterSoundEffects "0"
SET patchlist "logon.elysium-project.org"

 

I experience the same problem, I am very interested in finding solutions. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×