Jump to content
Sign in to follow this  
Xpirimint

Leveling a lower level pet

Recommended Posts

if mobs are in his level range, preferably 2-3 levels higher than him? even if they're grey to you he gets XP. this may not be how it's "supposed to work" but is how it works here. 

 

Share this post


Link to post
Share on other sites

As someone who has been leveling Lupos for the past couple weeks, gray mobs decidedly do not give your pet xp. At least at lvl 60.  Maybe there's something weird for pre-60, but I have not earned any xp for same-lvl mobs as my pet if it was gray for me.

Share this post


Link to post
Share on other sites
2 часа назад, Drakbak сказал:

incorrect, they need to be green for you

Incorrect, they need to be green for pet.

I leveled shitload of lvls on grey mobs (crimson whelplings in wetlands, pet The Rake)

Share this post


Link to post
Share on other sites

Gray mobs work on Anathema. I leveled two pets with mobs gray to me.

If they don't work on the server you're on, you can tell your pet to stay somewhere relatively safe - in like an LoS spot, not necessarily far away - and grind the mobs at the Altar of Storms in the Blasted Lands. It's pretty quiet, only miners, herbers and questers seem to come up that way, and the mobs are relatively easy to kill. You could also try the blood elves in Azshara, when I killed them they had no armor and my Autos did like 600+ to them in not-so-great gear. They're green to a 60.

Edited by Raziya

Share this post


Link to post
Share on other sites
2 hours ago, Xpirimint said:

Grey mobs didn't work on Elysium for me. Maybe it's a patch thing? Unijkeee, Oakenlix, maybe you're playing on Anathema / Darrowshire ?

I'm on Elysium, I have killed mobs of 40 lvl and 20, they both gave my pet kinda same exp.

Share this post


Link to post
Share on other sites
20 hours ago, unjkeee said:

Incorrect, they need to be green for pet.

I leveled shitload of lvls on grey mobs (crimson whelplings in wetlands, pet The Rake)

Maybe there's a bug out there that was preventing it from working that way for me.  I very specifically tried killing mobs equal in level to my pet (around lvl 30) and I didn't get a scrap of xp from it.  (Anathema server).

Really wasn't a huge deal for me, I ended up going to the coastal area of the Hinterlands and ground levels on the neutral turtles.  Easy to kill mobs that are green to me, yet won't aggro on the low-level pet.

Edited by Drakbak

Share this post


Link to post
Share on other sites

No XP on Zeth'Kur for gray mobs. I'm 48 and killed some level 23 (Lupos own level) in Duskwood. Not a singe XP for the pet.

EDIT:

After a relog he DO get XP for mobs not grey to HIM but grey to ME.

EDIT:

It seems that beeing in a party triggers the ?bug?. In a party Lupos didn't get XP. Solo he do get XP from gray mobs (gray for me, green to Lupos)

Edited by Dollylittle

Share this post


Link to post
Share on other sites

This a joke? Gave up on my Lupos bc i couldn't be arsed farming 60 mobs.
Must be a bug or a certain patch. I checked on LH Northdale, lower level mobs does give xp. LH Lightbringer works aswell. But i remember it not working on Elysium.

Share this post


Link to post
Share on other sites

I can confirm that mobs that are gray for you, can still give xp to your low lvl pet on nighthaven

Edited by Hildigunnur

Share this post


Link to post
Share on other sites

I am 49 and tamed a lvl 37 cat from Bad Lands and made a ticket in game and the gm said the best way to lvl him is killing things the same level as the pet. Even though they give me no xp it is the best way to level my cat.  Getting around 150xp per kill for him. But does any hunter here know what, if any, addon will show a pet xp bar and/or show the xp gain? I am using pfui if that matters or not.

Share this post


Link to post
Share on other sites

I confirm that your pet getting xp is dependent on if the mobs are green or better for your pet's level NOT your level. Also noted that when in a group doing world quests pet got zero xp. Wonder if that is as intended or not or is that a bug?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×